My screen is stuck loading when closing a register

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Setup

  • Retail POS for Mac or PC

Cause

The register was closed on another device or while the connection to the internet was interrupted. The issue is caused by a mismatch between local data on your device and our servers.

Solution

The first step is to reset data:

  1. Click Sell on the side navigation.
  2. Click Status.
  3. Click Reset Data.

The next step is to clear the browser cache:

  1. Type chrome://settings/content/all in the search bar.
  2. Search for lightspeed in the top right hand side.
  3. Click the trash icon to remove the saved data from your computer.
  4. Refresh Retail POS.

The Sell Screen should now load.

Additional Information

  • You can try logging into that register in an Incognito window (CTRL+Shift+N on PC or COMMAND+SHIFT+N on Mac) on Google Chrome to verify that it's closed before clearing your cache.

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