WooCommerce API couldn't be found at the supplied location

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Problem

Retail POS couldn't find the WooCommerce API at the supplied location. 

Setup

  • Retail POS for PC or Mac
  • WooCommerce Integration

Cause

Screen_Shot_2018-11-15_at_12.31.18_PM.png

This issue might occur if you have a security and firewall plugin on WooCommerce blocking the traffic. Retail POS is hosted on AWS servers and our IP addresses are changing daily/weekly. Also, each endpoint has a different IP address and will change in time. The other causes are IP addresses blocking from the AWS servers and POST request blocking to WooCommerce account.

Solution

We recommend to not filter incoming requests within the Plugin settings. Alternatively, you can whitelist the currently used IP addresses of services responsible for making those requests.

Additional Information

  • If you have a GoDaddy, Cloudflare etc. website firewall, you should whitelist the IP address from Amazon AWS if you are still running into issues after whitelisting the currently used IP address.
  • It is best to get in touch with a developer or the web hosting company to help you with this.
  • AWS IP Addresses

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